The download button on the LRS Connect My Documents screen is currently not working

Incident Report for NSW LRS

Resolved

The issue with the document download button in LRS Connect has been resolved.
Posted Aug 03, 2026 - 17:37 AEST

Identified

We have acknowledged the issue with the document download button in LRS Connect. We will keep you updated as soon as the issue is resolved.
Posted Aug 03, 2026 - 13:45 AEST
This incident affected: NSW LRS Connect (NSW LRS connect).